ISO/IEC 17343:2004Withdrawn

Information technology — Telecommunications and information exchange between systems — Corporate telecommunication networks — Signalling interworking between QSIG and SIP — Basic services

Technologies de l'information — Télécommunications et échange d'information entre systèmes — Réseaux de télécommunications d'entreprise — Signalisation d'interfonctionnement entre QSIG et SIP — Services de base

This edition has been replaced by ISO/IEC 17343:2007.

Abstract / scope

ISO/IEC 17343:2004 specifies signalling interworking between "QSIG" and the Session Initiation Protocol (SIP) in support of basic services within a corporate telecommunication network (CN). "QSIG" is a signalling protocol that operates between Private Integrated Services eXchanges (PINX) within a Private Integrated Services Network (PISN). A PISN provides circuit-switched basic services and supplementary services to its users. QSIG is specified in other Standards, in particular ISO/IEC 11572 (call control in support of basic services), ISO/IEC 11582 (generic functional protocol for the support of supplementary services) and a number of Standards specifying individual supplementary services. SIP is an application layer protocol for establishing, terminating and modifying multimedia sessions. It is typically carried over the Internet Protocol (IP) (IETF RFC 791 and IETF RFC 2460). Telephone calls are considered as a type of multimedia session where just audio is exchanged. SIP is defined in IETF RFC 3261.

Life cycle

Replaced by

ISO/IEC 17343:2007PublishedInformation technology — Telecommunications and information exchange between systems — Corporate telecommunication networks — Signalling interworking between QSIG and SIP — Basic servicesInternational Standard · Published 31 Oct 2007 · ISO/IEC JTC 1/SC 6